Certificate error

Incident Report for Pop

Resolved

This incident has been resolved.
Posted Mar 21, 2022 - 22:31 PDT

Update

We have identified the issue and are now rolling out a fix.
Posted Mar 21, 2022 - 21:46 PDT

Identified

Our cloud infrastructure's certificates weren't renewed correctly and meetings were no longer possible to join.
Posted Mar 21, 2022 - 19:15 PDT
This incident affected: Screen Service.